centos6.8无法安装锐速的解决方法

由于锐速官方尚不支持centos6.8,所以centos6.8想要安装锐速就要降级内核。锐速官方支持内核一览:

http://my.serverspeeder.com/ls.do?m=availables

首先需要确认自己的内核版本,输入命令uname -a,输出中有i686则为32位,有x86_64则为64位。

下载32位内核:

wget http://ftp.scientificlinux.org/linux/scientific/6.5/i386/updates/security/kernel-2.6.32-504.el6.i686.rpm

下载64位内核:

wget http://ftp.scientificlinux.org/linux/scientific/6.5/x86_64/updates/security/kernel-2.6.32-504.el6.x86_64.rpm

以32位系统为例下载后可以rpm -ivh kernel-2.6.32-504.el6.i686.rpm --force降级内核,然后reboot重启系统即可。

如果出现error: Failed dependencies: kernel-firmware >= 2.6.32-504.el6 is needed by kernel-2.6.32-504.el6.x86_64这样的错误,需要更新firmware

centos6.8无法安装锐速的解决方法

下载kernel-firmware-2.6.32-504.el6.noarch.rpm,然后执行rpm -Uvh kernel-firmware-2.6.32-504.el6.noarch.rpm你会发现进度条,再执行rpm -qa | grep kernel-firmware发现firmware安装成功。

这下我们再执行rpm -ivh kernel-2.6.32-504.el6.i686.rpm --force来装内核就成功了。如果还不行就算了。

weinxin
我的微信公众号
我的微信公众号扫一扫
广告也精彩
avatar

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:1   其中:访客  1   博主  0

    • avatar 逆知 0

      如果还不行就算了。。。 :lol: